Accueil site Tableur Programmation Outils XML Téléchargement Informations



Tableur

Documents

Fonctions logiques 
 
Repère
Documents
  Fonctions logiques
  SOMME.SI et NB.SI
Exercice 1
  Etape 1
  Etape 2
Exercice 2
  Etape 1
  Etape 2
Exercice 3
  Etape 1
  Etape 2
Exercice 4
  Etape 1
  Etape 2
  Etape 3
  Etape 4
  Etape 5
Exercice 5
  Etape 1
  Etape 2
  Etape 3
  Etape 4
Exercice 6
  Etape 1
  Etape 2
  Etape 3
Exercice 7
  Etape 1
  Etape 2
  Etape 3
Exercice 8
  Etape 1
  Etape 2
 
LES FONCTIONS LOGIQUES, LES OPERATEURS LOGIQUES

Les opérateurs logiques (=, >,<, <=; >= ,<>) permettent d'obtenir des arguments ou des opérandes de type logique.
Tous les tableurs possèdent la fonction SI.
Historiquement, le tableur Works et d'autres possèdaient les opérateurs logiques ET, OU, NON, par contre Excel, Calc d'OpenOffice n'acceptent que les fonctions correspondantes décrites ci-après.

- Les fonctions ET, OU :

La syntaxe est la suivante : ET (valeur logique 1; valeur logique 2;...)
OU (valeur logique 1; valeur logique 2;...)
Une valeur logique peut être le résultat de fonctions logiques ou d'expressions comportant des opérateurs logiques.

Ces fonctions renvoient la valeur "vrai" ou "faux", par exemple :
ET (A1>0 ;B1>0) renvoie la valeur "vrai" si et seulement si le contenu des deux cellules est positif.

- Les fonctions VRAI, FAUX n'ont pas d'argument, la syntaxe est VRAI(), FAUX(), elles renvoient respectivement la valeur "vrai" et la valeur "faux".

- La fonction NON :

La syntaxe est : NON (valeur logique)
Cette fonction permet de complémenter une valeur logique, par exemple :
NON ( VRAI() ) renvoie la valeur "faux"

Toutes ces fonctions logiques sont généralement utilisées comme arguments d'autres fonctions.

- La fonction SI :

La syntaxe est la suivante : SI (test logique; valeur si vrai; valeur si faux)
Le test logique peut comporter des opérateurs logiques , par exemple :

SI (B1 > 0; B1; 0)

Si la valeur du contenu de la cellule B1 est positive alors la valeur renvoyée par la fonction SI sera égale à la valeur du contenu de B1 sinon elle sera égale à 0.


Le test logique peut aussi être le résultat d'une fonction logique, par exemple dans la formule :

= SI (ET (A1>0; B1>0); 1; -1)

En fonction de la valeur renvoyée par la fonction ET, la cellule contenant la formule aura pour valeur 1 ou -1. Cette formule se traduit pour d'autres tableurs dont Works par :

= SI (A1 > 0 # ET # B1 > 0 ; 1 , -1)

Les tableurs comme Excel et Calc acceptent des opérandes textuels, par exemple :




formule, mode A1 : =SI(G1="";"";SI(G1=A1+D1;"BRAVO";"NON"))
formule, mode L1C1 : =SI(LC(-1)="";"";SI(LC(-1)=LC(-7)+LC(-4);"BRAVO";"NON"))

La formule ci-dessus est présente dans toutes les cellules de la 7ème colonne (G) .
Le début SI(G1="","";...) teste si la cellule placée une colonne avant sur la même ligne (cellule G1 où la réponse est saisie) est vide, auquel cas le contenu de la cellule contenant la formule restera vide sinon la deuxième partie de la formule ...;SI (G1 = A1+D1; "BRAVO"; "NON")) fera afficher BRAVO ou NON en fonction de la valeur du contenu de la cellule "réponse".

© FormTice avril 2020 - Tous droits réservés. Limitation à l'usage non commercial, privé ou scolaire.